GitHub Advisoryadvisory · Maven

GHSA-xgh5-gwq5-rpx8 Arbitrary javascript injection in Apache Jena

MEDIUM Published 2023-04-25 Modified 2023-05-05 Official page ↗
Aliases
CVE-2023-22665
Ecosystem
Maven
Packages
org.apache.jena:jena
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-917
Reviewed
2023-04-25

Affected packages

• Maven org.apache.jena:jena: < 4.8.0 → fixed in 4.8.0

Description

There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query.

Related

Alias · CVE (1)

  • CVE-2023-22665 There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. vulnerability

Weakness · CWE (1)

  • CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness

References