GitHub Advisoryadvisory · RubyGems

GHSA-xgr2-v94m-rc9g activesupport in Rails vulnerable to incorrect data conversion

HIGH Published 2017-10-24 Modified 2023-08-25 Official page ↗
Aliases
CVE-2013-0333
Ecosystem
RubyGems
Packages
activesupport
Severity
High
Weaknesses
CWE-74
Reviewed
2020-06-16

Affected packages

• RubyGems activesupport: >= 2.3.2, < 2.3.16 → fixed in 2.3.16 • RubyGems activesupport: >= 3.0.0, < 3.0.20 → fixed in 3.0.20

Description

`lib/active_support/json/backends/yaml.rb` in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Related

Alias · CVE (1)

  • CVE-2013-0333 lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data… vulnerability

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References