GitHub Advisoryadvisory · Maven

GHSA-xhcq-fv7x-grr2 Critical severity vulnerability that affects org.apache.solr:solr-core

CRITICAL Published 2019-03-14 Modified 2021-09-21 Official page ↗
Aliases
CVE-2019-0192
Ecosystem
Maven
Packages
org.apache.solr:solr-core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2020-06-16

Affected packages

• Maven org.apache.solr:solr-core: >= 5.0.0, < 7.0.0 → fixed in 7.0.0 • Maven org.apache.solr:solr-core: >= 6.0.0, < 7.0.0 → fixed in 7.0.0

Description

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Related

Alias · CVE (1)

  • CVE-2019-0192 In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References