GitHub Advisoryadvisory · Packagist
GHSA-xhfw-wjjc-4j5h Moodle Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1136
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.1, < 3.1.12 → fixed in 3.1.12
• Packagist moodle/moodle: >= 3.2, < 3.2.9 → fixed in 3.2.9
• Packagist moodle/moodle: >= 3.3, < 3.3.6 → fixed in 3.3.6
• Packagist moodle/moodle: >= 3.4, < 3.4.3 → fixed in 3.4.3
Description
An issue was discovered in Moodle 3.x. An authenticated user is allowed to add HTML blocks containing scripts to their Dashboard; this is normally not a security issue because a personal dashboard is visible to this user only. Through this security vulnerability, users can move such a block to other pages where they can be viewed by other users.
Related
Alias · CVE (1)
- CVE-2018-1136 An issue was discovered in Moodle 3.x. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness