GitHub Advisoryadvisory · Packagist
GHSA-xhfx-rm8q-c3xv Moodle Vulnerable to Reflected Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2021-20183
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-10
Affected packages
• Packagist moodle/moodle: >= 3.10, < 4.0.0-beta → fixed in 4.0.0-beta
Description
It was found in Moodle before version 4.0.0-beta that some search inputs were vulnerable to reflected Cross-site Scripting (XSS) due to insufficient escaping of search queries.
Related
Alias · CVE (1)
- CVE-2021-20183 It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness