GitHub Advisoryadvisory · Maven

GHSA-xhgq-h98j-859v Incorrect permission check in Jenkins GitLab Plugin allows enumerating credentials IDs

MEDIUM Published 2025-01-22 Modified 2025-01-22 Official page ↗
Aliases
CVE-2025-24397
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:gitlab-plugin
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-285, CWE-863
Reviewed
2025-01-22

Affected packages

• Maven org.jenkins-ci.plugins:gitlab-plugin: < 1.9.7 → fixed in 1.9.7

Description

The Jenkins GitLab Plugin 1.9.6 and earlier does not correctly perform a permission check in an HTTP endpoint. This allows attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate credential IDs of GitLab API token credentials and Secret text credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credential IDs in GitLab Plugin 1.9.7 requires Overall/Administer permission.

Related

Alias · CVE (1)

  • CVE-2025-24397 An incorrect permission check in Jenkins GitLab Plugin 1.9.6 and earlier allows attackers with global Item/Configure permission (while… vulnerability

Weakness · CWE (2)

  • CWE-285 Improper Authorization weakness
  • CWE-863 Incorrect Authorization weakness

References