GitHub Advisoryadvisory · Maven
GHSA-xj29-gfww-j67g Jenkins JaCoCo Plugin vulnerable to Stored Cross-site Scripting
HIGH
Official page ↗
- Aliases
- CVE-2023-28669
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:jacoco
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2023-04-03
Affected packages
• Maven org.jenkins-ci.plugins:jacoco: < 3.3.2.1 → fixed in 3.3.2.1
Description
Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action. Version 3.3.2.1 escapes class and method names shown on the UI.
Related
Alias · CVE (1)
- CVE-2023-28669 Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness