GitHub Advisoryadvisory · RubyGems

GHSA-xj5v-6v4g-jfw6 Rack has possible DoS Vulnerability with Range Header

LOW Published 2024-02-28 Modified 2024-02-29 Official page ↗
Aliases
CVE-2024-26141
Ecosystem
RubyGems
Packages
rack
Severity
Low
Weaknesses
CWE-400
Reviewed
2024-02-28

Affected packages

• RubyGems rack: >= 3.0.0, < 3.0.9.1 → fixed in 3.0.9.1 • RubyGems rack: >= 1.3.0, < 2.2.8.1 → fixed in 2.2.8.1

Description

Possible DoS Vulnerability with Range Header in Rack There is a possible DoS vulnerability relating to the Range request header in Rack. This vulnerability has been assigned the CVE identifier CVE-2024-26141. Versions Affected: >= 1.3.0. Not affected: < 1.3.0 Fixed Versions: 3.0.9.1, 2.2.8.1 Impact ------ Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the `Rack::File` middleware or the `Rack::Utils.byte_ranges` methods (this includes Rails applications). Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- There are no feasible workarounds for this issue. Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. • 3-0-range.patch - Patch for 3.0 series • 2-2-range.patch - Patch for 2.2 series Credits ------- Thank you ooooooo_q for the report and patch

Related

Alias · CVE (1)

  • CVE-2024-26141 Rack is a modular Ruby web server interface. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References