GitHub Advisoryadvisory · npm
GHSA-xjh9-v7x6-24jw @fastify/busboy vulnerable to Denial of Service via oversized multipart boundary
HIGH
Official page ↗
- Aliases
- CVE-2026-19484
- Ecosystem
- npm
- Packages
- @fastify/busboy
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1322, CWE-835
- Reviewed
- 2026-10-02
Affected packages
• npm @fastify/busboy: >= 3.1.0, < 3.2.1 → fixed in 3.2.1
Description
Impact
Versions of `@fastify/busboy` from 3.1.0 and prior to 3.2.1 are vulnerable to a Denial of Service. The vendored streaming multipart search stores its default skip distance in a `Uint8Array(256)`. A multipart boundary of exactly 252 bytes makes the search needle 256 bytes, and the table entry wraps to zero, so a crafted request keeps the search in a CPU-bound loop and stalls the Node.js event loop. An unauthenticated client can trigger this with a single small request. Applications that use `@fastify/busboy` to parse multipart/form-data, directly or through `@fastify/multipart`, are affected.
Patches
Fixed in version 3.2.1.
Workarounds
Validate the multipart boundary before parsing and reject any boundary longer than the RFC 2046 limit of 70 characters (for example at a reverse proxy or in an onRequest hook). Upgrading to 3.2.1 removes the issue.
Related
Alias · CVE (1)
- CVE-2026-19484 @fastify/busboy is a multipart form-data parser. vulnerability
References
- https://github.com/fastify/busboy/security/advisories/GHSA-xjh9-v7x6-24jw web
- https://nvd.nist.gov/vuln/detail/CVE-2026-19484 advisory
- https://github.com/fastify/busboy/commit/632a237e7fb6b3b7a30e0de8fab2ee72ca5bf722 web
- https://cna.openjsf.org/security-advisories.html web
- https://github.com/fastify/busboy package
- https://github.com/fastify/busboy/releases/tag/v3.2.1 web