GitHub Advisoryadvisory · Maven

GHSA-xjp4-hw94-mvp5 Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()

MEDIUM Published 2024-03-21 Modified 2025-02-13 Official page ↗
Aliases
CVE-2024-29131
Ecosystem
Maven
Packages
org.apache.commons:commons-configuration2
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
Weaknesses
CWE-787
Reviewed
2024-03-21

Affected packages

• Maven org.apache.commons:commons-configuration2: >= 2.0, < 2.10.1 → fixed in 2.10.1

Description

This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' when adding a property in 'AbstractListDelimiterHandler.flattenIterator()'. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-29131 Out-of-bounds Write vulnerability in Apache Commons Configuration.This issue affects Apache Commons Configuration: from 2.0 before 2.10.1. vulnerability

Weakness · CWE (1)

  • CWE-787 Out-of-bounds Write weakness

References