GitHub Advisoryadvisory · RubyGems

GHSA-xjqg-9jvg-fgx2 Nokogiri subject to DoS via libxml2 vulnerability

HIGH Published 2018-08-21 Modified 2023-03-13 Official page ↗
Aliases
CVE-2015-5312
Ecosystem
RubyGems
Packages
nokogiri
Severity
High
Weaknesses
CWE-400
Reviewed
2020-06-16

Affected packages

• RubyGems nokogiri: >= 1.6.0, < 1.6.7.1 → fixed in 1.6.7.1

Description

The xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.3 (as used in nokogiri before 1.6.7.1) does not properly prevent entity expansion, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted XML data, a different vulnerability than CVE-2014-3660.

Related

Alias · CVE (1)

  • CVE-2015-5312 The xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.3 does not properly prevent entity expansion, which allows… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References