GitHub Advisoryadvisory · Maven
GHSA-xjrg-6fv9-6rjg Stored XSS vulnerability in Jenkins Build With Parameters Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21628
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:build-with-parameters
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-15
Affected packages
• Maven org.jenkins-ci.plugins:build-with-parameters: < 1.5.1 → fixed in 1.5.1
Description
Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.
Jenkins Build With Parameters Plugin 1.5.1 escapes parameter names and descriptions.
Related
Alias · CVE (1)
- CVE-2021-21628 Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions, resulting in a stored cross-site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21628 advisory
- https://github.com/jenkinsci/build-with-parameters-plugin/commit/edbc286cfd1419a40589a8c40d03ef9fe71dccf9 web
- https://github.com/jenkinsci/build-with-parameters-plugin package
- https://www.jenkins.io/security/advisory/2021-03-30/#SECURITY-2231 web
- http://www.openwall.com/lists/oss-security/2021/03/30/1 web