GitHub Advisoryadvisory · Packagist

GHSA-xjw3-5r5c-m5ph typo3 Security fix for Flow Swift Mailer package

HIGH Published 2024-06-05 Modified 2024-06-05 Official page ↗
Ecosystem
Packagist
Packages
typo3/swiftmailer
Severity
High
Reviewed
2024-06-05

Affected packages

• Packagist typo3/swiftmailer: >= 4.1.0, < 4.1.99 → fixed in 4.1.99 • Packagist typo3/swiftmailer: >= 5.4.0, < 5.4.5 → fixed in 5.4.5

Description

A remote code execution vulnerability has been found in the Swift Mailer library (swiftmailer/swiftmailer) recently. See this advisory for details. If you are not using the default mail() transport, this particular problem does not affect you. Upgrading is of course still recommended!

References