GitHub Advisoryadvisory · Go

GHSA-xmfh-3ccg-c9fx Mattermost has an Incorrect Authorization issue

LOW Published 2026-06-22 Modified 2026-09-22 Official page ↗
Aliases
CVE-2026-8823
Ecosystem
Go
Packages
github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
Weaknesses
CWE-863
Reviewed
2026-09-22

Affected packages

• Go github.com/mattermost/mattermost-server: >= 11.7.0, < 11.7.1 → fixed in 11.7.1 • Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.18 → fixed in 10.11.18 • Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20260518160100-9bd77d3fc4d2 → fixed in 8.0.0-20260518160100-9bd77d3fc4d2

Description

Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to validate bot targets when demoting users to guests which allows a lower-privileged administrator to degrade arbitrary bot accounts via the standard demote-user API.. Mattermost Advisory ID: MMSA-2026-00669

Related

Alias · CVE (1)

  • CVE-2026-8823 Mattermost versions 11.7.x <= 11.7.0, 10.11.x <= 10.11.17 fail to validate bot targets when demoting users to guests which allows a… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References