GitHub Advisoryadvisory · Packagist

GHSA-xp2f-9mx3-3c6p Moodle PostScript Code Injection

CRITICAL Published 2022-07-26 Modified 2024-04-23 Official page ↗
Aliases
CVE-2022-35649
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2024-04-23

Affected packages

• Packagist moodle/moodle: >= 3.9, < 3.9.15 → fixed in 3.9.15 • Packagist moodle/moodle: >= 3.11, < 3.11.8 → fixed in 3.11.8 • Packagist moodle/moodle: >= 4.0, < 4.0.2 → fixed in 4.0.2

Description

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Related

Alias · CVE (1)

  • CVE-2022-35649 The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References