GitHub Advisoryadvisory · Packagist

GHSA-xqcf-vgqc-pcmg Moodle blind Server-Side Request Forgery (SSRF) vulnerability in LTI provider library

CRITICAL Published 2022-11-25 Modified 2025-04-29 Official page ↗
Aliases
CVE-2022-45152
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-918
Reviewed
2024-04-23

Affected packages

• Packagist moodle/moodle: >= 3.9, < 3.9.18 → fixed in 3.9.18 • Packagist moodle/moodle: >= 3.11, < 3.11.11 → fixed in 3.11.11 • Packagist moodle/moodle: >= 4.0, < 4.0.5 → fixed in 4.0.5

Description

A blind Server-Side Request Forgery (SSRF) vulnerability was found in Moodle. This flaw exists due to insufficient validation of user-supplied input in LTI provider library. The library does not utilise Moodle's inbuilt cURL helper, which resulted in a blind SSRF risk. An attacker can send a specially crafted HTTP request and trick the application to initiate requests to arbitrary systems. This vulnerability allows a remote attacker to perform SSRF attacks.

Related

Alias · CVE (1)

  • CVE-2022-45152 A blind Server-Side Request Forgery (SSRF) vulnerability was found in Moodle. vulnerability

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References