GitHub Advisoryadvisory · PyPI

GHSA-xqxw-r767-67m7 mem0ai mem0 has an Improper Input Validation Issue

LOW Published 2026-05-02 Modified 2026-05-07 Official page ↗
Aliases
CVE-2026-7597
Ecosystem
PyPI
Packages
mem0ai
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2026-05-07

Affected packages

• PyPI mem0ai: < 2.0.0b2 → fixed in 2.0.0b2

Description

A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.

Related

Alias · CVE (1)

  • CVE-2026-7597 A vulnerability was found in mem0ai mem0 up to 1.0.11. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References