GitHub Advisoryadvisory · Go

GHSA-xr9q-h9c7-xw8q Rancher allows an unauthenticated stack overflow in /v3-public/authproviders API

HIGH Published 2025-02-27 Modified 2025-05-27 Official page ↗
Aliases
CVE-2025-23388
Ecosystem
Go
Packages
github.com/rancher/rancher
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
Weaknesses
CWE-121
Reviewed
2025-02-27

Affected packages

• Go github.com/rancher/rancher: >= 2.8.0, < 2.8.13 → fixed in 2.8.13 • Go github.com/rancher/rancher: >= 2.9.0, < 2.9.7 → fixed in 2.9.7 • Go github.com/rancher/rancher: >= 2.10.0, < 2.10.3 → fixed in 2.10.3

Description

Impact An unauthenticated stack overflow crash, leading to a denial of service (DoS), was identified in Rancher’s `/v3-public/authproviders` public API endpoint. A malicious user could submit data to the API which would cause the Rancher server to crash, but no malicious or incorrect data would actually be written in the API. The downstream clusters, i.e., the clusters managed by Rancher, are not affected by this issue. This vulnerability affects those using external authentication providers as well as Rancher’s local authentication. Patches The patch includes the removal of unnecessary HTTP methods of the specific API. Patched versions include releases `v2.8.13`, `v2.9.7` and `v2.10.3`. Workarounds There are no workarounds for this issue. Users are recommended to upgrade, as soon as possible, to a version of Rancher Manager that contains the fix. References If you have any questions or comments about this advisory: • Reach out to the SUSE Rancher Security team for security related inquiries. • Open an issue in the Rancher repository. • Verify with our support matrix and product support lifecycle.

Related

Alias · CVE (1)

  • CVE-2025-23388 A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before… vulnerability

Weakness · CWE (1)

  • CWE-121 Stack-based Buffer Overflow weakness

References