GitHub Advisoryadvisory · npm

GHSA-xrc4-737v-9q75 OpenZeppelin Contracts's GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals

HIGH Published 2022-08-18 Modified 2022-08-18 Official page ↗
Aliases
CVE-2022-31198
Ecosystem
npm
Packages
@openzeppelin/contracts, @openzeppelin/contracts-upgradeable
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-682
Reviewed
2022-08-18

Affected packages

• npm @openzeppelin/contracts: >= 4.3.0, < 4.7.2 → fixed in 4.7.2 • npm @openzeppelin/contracts-upgradeable: >= 4.3.0, < 4.7.2 → fixed in 4.7.2

Description

Impact This issue concerns instances of Governor that use the module `GovernorVotesQuorumFraction`, a mechanism that determines quorum requirements as a percentage of the voting token's total supply. In affected instances, when a proposal is passed to lower the quorum requirement, past proposals may become executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement. Analysis of instances on chain found only one proposal that met this condition, and we are actively monitoring for new occurrences of this particular issue. Patches This issue has been patched in v4.7.2. Workarounds Avoid lowering quorum requirements if a past proposal was defeated for lack of quorum. References https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3561 For more information If you have any questions or comments about this advisory, or need assistance deploying the fix, email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2022-31198 OpenZeppelin Contracts is a library for secure smart contract development. vulnerability

Weakness · CWE (1)

  • CWE-682 Incorrect Calculation weakness

References