GitHub Advisoryadvisory · npm
GHSA-xrrh-p7f2-27vm decolua 9router vulnerable to authorization bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2026-5842
- Ecosystem
- npm
- Packages
- 9router
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-285
- Reviewed
- 2026-04-10
Affected packages
• npm 9router: < 0.3.75 → fixed in 0.3.75
Description
A security vulnerability has been detected in decolua 9router up to 0.3.47. The impacted element is an unknown function of the file /api of the component Administrative API Endpoint. The manipulation leads to authorization bypass. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 0.3.75 is sufficient to resolve this issue. It is suggested to upgrade the affected component.
Related
Alias · CVE (1)
- CVE-2026-5842 A security vulnerability has been detected in decolua 9router up to 0.3.47. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2026-5842 advisory
- https://github.com/decolua/9router/issues/431 web
- https://github.com/decolua/9router/issues/431#issuecomment-4140163867 web
- https://github.com/decolua/9router package
- https://github.com/decolua/9router/releases/tag/v0.3.75 web
- https://github.com/deepcat1337/Free_Api_Exploit/tree/main web
- https://vuldb.com/submit/790003 web
- https://vuldb.com/vuln/356298 web
- https://vuldb.com/vuln/356298/cti web