GitHub Advisoryadvisory · PyPI
GHSA-xv64-8p4r-94gq pgAdmin Cross-site Scripting vulnerability in /settings/store API response json payload
HIGH
Official page ↗
- Aliases
- CVE-2024-4216
- Ecosystem
- PyPI
- Packages
- pgAdmin4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-03
Affected packages
• PyPI pgAdmin4: < 8.6 → fixed in 8.6
Description
pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. This vulnerability allows attackers to execute malicious script at the client end.
Related
Alias · CVE (1)
- CVE-2024-4216 pgAdmin <= 8.5 is affected by XSS vulnerability in /settings/store API response json payload. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-4216 advisory
- https://github.com/pgadmin-org/pgadmin4/issues/7282 web
- https://github.com/pgadmin-org/pgadmin4/commit/e384c9665ae2e72376be7cefa8e652efcee93767 web
- https://github.com/pgadmin-org/pgadmin4 package
- https://lists.fedoraproject.org/archives/list/[email protected]/message/T2YFVCB4HCXU3FQBZ5XTWJZWSZUDNCXE web