GitHub Advisoryadvisory · RubyGems

GHSA-xv9w-7v6q-hpjh fluent-plugin-s3 Vulnerable to Denial of Service (DoS) via Decompression Bomb in `in_s3`

LOW Published 2026-06-26 Modified 2026-06-26 Official page ↗
Aliases
CVE-2026-44162
Ecosystem
RubyGems
Packages
fluent-plugin-s3
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-770
Reviewed
2026-06-26

Affected packages

• RubyGems fluent-plugin-s3: >= 0.7.0, < 1.8.5 → fixed in 1.8.5

Description

The `fluent-plugin-s3` plugin (specifically the `in_s3` input plugin) supports reading and decompressing heavily compressed files (such as `gzip`, `lzma2`, and `lzop`) from Amazon S3. It was discovered that the plugin read the entire decompressed payload into memory at once without enforcing a strict size limit. If an attacker has sufficient permissions to upload files to the monitored S3 bucket, they can upload a maliciously crafted, highly compressed file. When Fluentd attempts to decompress this file, it will expand to an excessive size and it will consume significant system resources. Impact This vulnerability allows for a Denial of Service (DoS) attack via memory exhaustion. The rapid memory consumption during decompression can lead to an Out-of-Memory kill of the Fluentd process by the operating system, This results in the disruption of all log collection on the affected node. Patches v1.8.5 Workarounds If an immediate upgrade is not possible, mitigate the risk by applying strict IAM access controls: 1. Restrict Bucket Access • Ensure that write (PUT) access to the S3 bucket monitored by `in_s3` is strictly limited to trusted services and administrators. Prevent any public or untrusted uploads to the S3 bucket.

Related

Alias · CVE (1)

  • CVE-2026-44162 fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References