GitHub Advisoryadvisory · Packagist
GHSA-xvmh-25jw-gmmm Moodle affected by a code injection vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-67847
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2026-01-23
Affected packages
• Packagist moodle/moodle: >= 5.1.0-beta, < 5.1.1 → fixed in 5.1.1
• Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.4 → fixed in 5.0.4
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.8 → fixed in 4.5.8
• Packagist moodle/moodle: >= 4.2.0-beta, < 4.4.12 → fixed in 4.4.12
• Packagist moodle/moodle: < 4.1.22 → fixed in 4.1.22
Description
A flaw was found in Moodle. An attacker with access to the restore interface could trigger server-side execution of arbitrary code. This is due to insufficient validation of restore input, which leads to unintended interpretation by core restore routines. Successful exploitation could result in a full compromise of the Moodle application.
Related
Alias · CVE (1)
- CVE-2025-67847 A flaw was found in Moodle. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness