GitHub Advisoryadvisory · Go
GHSA-xvq6-h898-wcj8 Mattermost denial of service vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2023-5967
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server/v6, github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-754
- Reviewed
- 2023-11-08
Affected packages
• Go github.com/mattermost/mattermost-server/v6: < 7.8.12 → fixed in 7.8.12
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0, < 8.0.4 → fixed in 8.0.4
• Go github.com/mattermost/mattermost/server/v8: >= 8.1.0, < 8.1.3 → fixed in 8.1.3
• Go github.com/mattermost/mattermost/server/v8: >= 9.0.0, < 9.0.1 → fixed in 9.0.1
Description
Mattermost fails to properly validate requests to the Calls plugin, allowing an attacker sending a request without a User Agent header to cause a panic and crash the Calls plugin
Related
Alias · CVE (1)
- CVE-2023-5967 Mattermost fails to properly validate requests to the Calls plugin, allowing an attacker sending a request without a User Agent header to… vulnerability
Weakness · CWE (1)
- CWE-754 Improper Check for Unusual or Exceptional Conditions weakness