GitHub Advisoryadvisory · Maven
GHSA-xvqc-pp94-fmpx Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound
MEDIUM
Official page ↗
- Aliases
- CVE-2026-40046
- Ecosystem
- Maven
- Packages
- org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all, org.apache.activemq:activemq-mqtt
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-190
- Reviewed
- 2026-04-10
Affected packages
• Maven org.apache.activemq:apache-activemq: >= 6.0.0, < 6.2.4 → fixed in 6.2.4
• Maven org.apache.activemq:activemq-all: >= 6.0.0, < 6.2.4 → fixed in 6.2.4
• Maven org.apache.activemq:activemq-mqtt: >= 6.0.0, < 6.2.4 → fixed in 6.2.4
Description
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT.
The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4.
Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.
Related
Alias · CVE (1)
- CVE-2026-40046 Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. vulnerability
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness