GitHub Advisoryadvisory · Maven
GHSA-xvv8-8wh9-9fh2 Keycloak Authentication Error
MEDIUM
Official page ↗
- Aliases
- CVE-2018-10894
- Ecosystem
- Maven
- Packages
- org.keycloak:keycloak-saml-adapter-core, org.keycloak:keycloak-services
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-295
- Reviewed
- 2023-07-21
Affected packages
• Maven org.keycloak:keycloak-saml-adapter-core: < 4.4.0.Final → fixed in 4.4.0.Final
• Maven org.keycloak:keycloak-services: < 4.4.0.Final → fixed in 4.4.0.Final
Description
It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. A malicious user could use this to access unauthorized data or possibly conduct further attacks.
Related
Alias · CVE (1)
- CVE-2018-10894 It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10894 advisory
- https://github.com/keycloak/keycloak/commit/812e76c39b1e693e8f11e5549cca2c90631f372e web
- https://access.redhat.com/errata/RHSA-2018:3592 web
- https://access.redhat.com/errata/RHSA-2018:3593 web
- https://access.redhat.com/errata/RHSA-2018:3595 web
- https://access.redhat.com/errata/RHSA-2019:0877 web
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10894 web
- https://github.com/keycloak/keycloak package