GitHub Advisoryadvisory · Maven

GHSA-xvxq-hq48-xphm Sandbox bypass in Script Security Plugin

CRITICAL Published 2022-05-13 Modified 2025-10-22 Official page ↗
Aliases
CVE-2019-1003029
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:script-security
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:H
Weaknesses
CWE-693
Reviewed
2022-06-01

Affected packages

• Maven org.jenkins-ci.plugins:script-security: < 1.54 → fixed in 1.54

Description

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.

Related

Alias · CVE (1)

  • CVE-2019-1003029 A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in… vulnerability

Weakness · CWE (1)

  • CWE-693 Protection Mechanism Failure weakness

References