GitHub Advisoryadvisory · npm
GHSA-xw5p-hw6r-2j98 Denial of service in fastify
MEDIUM
Official page ↗
- Aliases
- CVE-2020-8192
- Ecosystem
- npm
- Packages
- fastify
- Severity
- Moderate
- Weaknesses
- CWE-400
- Reviewed
- 2020-08-03
Affected packages
• npm fastify: < 2.15.1 → fixed in 2.15.1
Description
A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows a malicious user to trigger resource exhaustion (when the allErrors option is used) with specially crafted schemas.
Related
Alias · CVE (1)
- CVE-2020-8192 A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows a malicious user to trigger resource exhaustion… vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness