GitHub Advisoryadvisory · Packagist

GHSA-xwhj-pqcg-8rcr CakePHP vulnerable to Cross-site Scripting in some development error pages

MEDIUM Published 2023-01-20 Modified 2023-01-20 Official page ↗
Ecosystem
Packagist
Packages
cakephp/cakephp
Severity
Moderate
Reviewed
2023-01-20

Affected packages

• Packagist cakephp/cakephp: >= 3.4.0, < 3.4.14 → fixed in 3.4.14 • Packagist cakephp/cakephp: >= 3.5.0, < 3.5.17 → fixed in 3.5.17 • Packagist cakephp/cakephp: >= 3.6.0, < 3.6.4 → fixed in 3.6.4

Description

CakePHP 3.4 prior to 3.4.14, 3.5 prior to 3.5.17, and 3.6 prior to 3.6.4 contains a cross-site-scripting (XSS) vulnerability in the development only `missing route` and `duplicate named route` error pages.

References