GitHub Advisoryadvisory · Packagist

GHSA-xwrh-qxmc-x8c8 Concrete CMS Cross-site Scripting (XSS) in the Advanced File Search Filter

LOW Published 2024-04-03 Modified 2024-04-03 Official page ↗
Aliases
CVE-2024-3178
Ecosystem
Packagist
Packages
concrete5/concrete5
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L
Weaknesses
CWE-20, CWE-79
Reviewed
2024-04-03

Affected packages

• Packagist concrete5/concrete5: >= 9.0.0RC1, < 9.2.8 → fixed in 9.2.8 • Packagist concrete5/concrete5: < 8.5.16 → fixed in 8.5.16

Description

Concrete CMS versions 9 below 9.2.8 and versions below 8.5.16 are vulnerable to Cross-site Scripting (XSS) in the Advanced File Search Filter. Prior to the fix, a rogue administrator could add malicious code in the file manager because of insufficient validation of administrator provided data. All administrators have access to the File Manager and hence could create a search filter with the malicious code attached. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator .

Related

Alias · CVE (1)

  • CVE-2024-3178 Concrete CMS versions 9 below 9.2.8 and versions below 8.5.16 are vulnerable to Cross-site Scripting (XSS) in the Advanced File Search… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References