GitHub Advisoryadvisory · PyPI

GHSA-xx6g-jj35-pxjv Cross Site Scripting vulnerability in wsgidav when directory browsing is enabled

HIGH Published 2022-11-16 Modified 2024-11-19 Official page ↗
Aliases
CVE-2022-41905
Ecosystem
PyPI
Packages
wsgidav
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2022-11-16

Affected packages

• PyPI wsgidav: >= 3.0.0a1, < 4.1.0 → fixed in 4.1.0

Description

Impact Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. Patches Users can upgrade to v4.1.0 Workarounds Set `dir_browser.enable = False` in the configuration. For instance, when using a Python dictionary to configure the library: ``` config = { # your normal configuration "dir_browser": { "enable": False }, } app = WsgiDAVApp(config) ``` For more information Note that an attacker cannot exploit this vulnerability, by simply uploading a file or folder with a manipulated file name. However if the WsgiDAV library is used in a scenario where untrusted data is displayed in the directory browser's user interface (e.g. 'realm' or user name, ...) XSS may happen. If you have any questions or comments about this advisory: • Open an issue in mar10/wsgidav • See the security policy

Related

Alias · CVE (1)

  • CVE-2022-41905 WsgiDAV is a generic and extendable WebDAV server based on WSGI. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References