GitHub Advisoryadvisory · Maven

GHSA-xx7v-hqxh-cjr9 Apache Struts is Vulnerable to DoS via File Leak

HIGH Published 2025-12-01 Modified 2025-12-03 Official page ↗
Aliases
CVE-2025-64775
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-459
Reviewed
2025-12-03

Affected packages

• Maven org.apache.struts:struts2-core: >= 6.0.0, < 6.8.0 → fixed in 6.8.0 • Maven org.apache.struts:struts2-core: >= 7.0.0, < 7.1.1 → fixed in 7.1.1 • Maven org.apache.struts:struts2-core: >= 2.0.0, <= 2.3.37 (no fix yet) • Maven org.apache.struts:struts2-core: >= 2.5.0, <= 2.5.33 (no fix yet)

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-64775 Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. vulnerability

Weakness · CWE (1)

  • CWE-459 Incomplete Cleanup weakness

References