GitHub Advisoryadvisory · Packagist

GHSA-xx8f-qf9f-5fgw Remote code execution in zendframework and laminas-http

CRITICAL Published 2021-06-08 Modified 2024-04-22 Official page ↗
Aliases
CVE-2021-3007
Ecosystem
Packagist
Packages
zendframework/zendframework, laminas/laminas-http
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2021-04-07

Affected packages

• Packagist zendframework/zendframework: <= 3.0.0 (no fix yet) • Packagist laminas/laminas-http: < 2.14.2 → fixed in 2.14.2

Description

Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code execution if the content is controllable, related to the __destruct method of the Zend\Http\Response\Stream class in Stream.php. NOTE: Zend Framework is no longer supported by the maintainer. NOTE: the laminas-http vendor considers this a "vulnerability in the PHP language itself" but has added certain type checking as a way to prevent exploitation in (unrecommended) use cases where attacker-supplied data can be deserialized.

Related

Alias · CVE (1)

  • CVE-2021-3007 Laminas Project laminas-http before 2.14.2, and Zend Framework 3.0.0, has a deserialization vulnerability that can lead to remote code… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References