GitHub Advisoryadvisory · PyPI
GHSA-xxfm-vmcf-g33f Improper Handling of Insufficient Permissions in `wagtail.contrib.settings`
MEDIUM
Official page ↗
- Aliases
- CVE-2024-35228
- Ecosystem
- PyPI
- Packages
- wagtail
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-280
- Reviewed
- 2024-06-02
Affected packages
• PyPI wagtail: >= 6.0.0, < 6.0.5 → fixed in 6.0.5
• PyPI wagtail: >= 6.1.0, < 6.1.2 → fixed in 6.1.2
Description
Impact
Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected.
Workarounds
No workaround is available.
Acknowledgements
Many thanks to Victor Miti for reporting this issue.
For more information
If you have any questions or comments about this advisory:
• Visit Wagtail's support channels
• Email us at [email protected] (view our security policy for more information).
Related
Alias · CVE (1)
- CVE-2024-35228 Wagtail is an open source content management system built on Django. vulnerability
Weakness · CWE (1)
- CWE-280 Improper Handling of Insufficient Permissions or Privileges weakness