GitHub Advisoryadvisory · PyPI

GHSA-xxj9-f6rv-m3x4 Django denial-of-service attack in the intcomma template filter

HIGH Published 2024-02-07 Modified 2025-11-04 Official page ↗
Aliases
CVE-2024-24680
Ecosystem
PyPI
Packages
Django
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-770
Reviewed
2024-02-07

Affected packages

• PyPI Django: >= 3.2, < 3.2.24 → fixed in 3.2.24 • PyPI Django: >= 4.2, < 4.2.10 → fixed in 4.2.10 • PyPI Django: >= 5.0, < 5.0.2 → fixed in 5.0.2

Description

An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.

Related

Alias · CVE (1)

  • CVE-2024-24680 An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. vulnerability

Weakness · CWE (1)

  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References