GitHub Advisoryadvisory · RubyGems

GHSA-xxr8-833v-c7wc Cross-site Scripting vulnerability in i18n translations helper method

MEDIUM Published 2017-10-24 Modified 2023-05-26 Official page ↗
Aliases
CVE-2011-4319
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 3.0.0, < 3.0.11 → fixed in 3.0.11 • RubyGems actionpack: >= 3.1.0, < 3.1.2 → fixed in 3.1.2

Description

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Related

Alias · CVE (1)

  • CVE-2011-4319 Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References