CVEvulnerability
CVE-2018-1000086
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2018-03-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.0 ([email protected])
- 8.8 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 6.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-352
Description
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Affected configurations
• npr pym.js (>= 0.4.2 <= 1.3.1)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- http://blog.apps.npr.org/2018/02/15/pym-security-vulnerability.html Vendor Advisory
- https://github.com/nprapps/pym.js Product
- https://github.com/nprapps/pym.js/issues/170 Third Party Advisory
- http://blog.apps.npr.org/2018/02/15/pym-security-vulnerability.html Vendor Advisory
- https://github.com/nprapps/pym.js Product
- https://github.com/nprapps/pym.js/issues/170 Third Party Advisory