CVEvulnerability
CVE-2020-16250
8.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2020-08-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-290, CWE-345
Description
HashiCorp Vault and Vault Enterprise versions 0.7.1 and newer, when configured with the AWS IAM auth method, may be vulnerable to authentication bypass. Fixed in 1.2.5, 1.3.8, 1.4.4, and 1.5.1..
Affected configurations
• hashicorp vault (>= 0.7.1 < 1.2.5)
• hashicorp vault (>= 1.3.0 < 1.3.8)
• hashicorp vault (>= 1.4.0 < 1.4.4)
• hashicorp vault (>= 1.5.0 < 1.5.1)
Related
References
- http://packetstormsecurity.com/files/159478/Hashicorp-Vault-AWS-IAM-Integration-Authentication-Bypass.html Third Party Advisory, VDB Entry
- https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151 Release Notes, Vendor Advisory
- https://www.hashicorp.com/blog/category/vault/ Product, Vendor Advisory
- http://packetstormsecurity.com/files/159478/Hashicorp-Vault-AWS-IAM-Integration-Authentication-Bypass.html Third Party Advisory, VDB Entry
- https://github.com/hashicorp/vault/blob/master/CHANGELOG.md#151 Release Notes, Vendor Advisory
- https://www.hashicorp.com/blog/category/vault/ Product, Vendor Advisory