CVEvulnerability

CVE-2022-24858

6.1 MEDIUM Published 2022-04-19 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-04-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.1 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
CVSS 3.1 ([email protected])
6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0 ([email protected])
5.8 MEDIUM — AV:N/AC:M/Au:N/C:P/I:P/A:N
Weaknesses
CWE-290, CWE-601

Description

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

Affected configurations

• nextauth.js next-auth (>= 3.0.0 < 3.29.2) • nextauth.js next-auth (>= 4.0.0 < 4.3.2)

Related

Weakness · CWE (2)

  • CWE-290 Authentication Bypass by Spoofing weakness
  • CWE-601 URL Redirection to Untrusted Site weakness

References