CVEvulnerability

CVE-2023-2279

5.4 MEDIUM Published 2023-08-31 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-08-31
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Weaknesses
CWE-352

Description

The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2

Affected configurations

• wpdirectorykit wp directory kit (< 1.2.2)

Related

Weakness · CWE (1)

  • CWE-352 Cross-Site Request Forgery weakness

References