CVEvulnerability

CVE-2023-29197

7.5 HIGH Published 2023-04-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-04-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-436

Description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.

Affected configurations

• guzzlephp psr-7 (< 1.9.1) • guzzlephp psr-7 (>= 2.0.0 < 2.4.5) • fedoraproject fedora 37 • fedoraproject fedora 38

Related

Weakness · CWE (1)

  • CWE-436 Interpretation Conflict weakness

References