CVEvulnerability
CVE-2023-49920
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-12-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-352
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent.
Users are advised to upgrade to version 2.8.0 or later which is not affected
Affected configurations
• apache airflow (>= 2.7.0 <= 2.7.3)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- http://www.openwall.com/lists/oss-security/2023/12/21/3 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/36026 Patch
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq Mailing List, Third Party Advisory
- http://www.openwall.com/lists/oss-security/2023/12/21/3 Mailing List, Third Party Advisory
- https://github.com/apache/airflow/pull/36026 Patch
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq Mailing List, Third Party Advisory