CVEvulnerability
CVE-2024-10975
7.7 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-11-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- Weaknesses
- CWE-863
Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Affected configurations
• hashicorp nomad (>= 1.3.0 < 1.7.15)
• hashicorp nomad (>= 1.3.0 < 1.9.2)
• hashicorp nomad (>= 1.8.0 < 1.8.7)
• hashicorp nomad (>= 1.9.0 < 1.9.2)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness