CVEvulnerability
CVE-2024-1329
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-02-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-59, CWE-610
Description
HashiCorp Nomad and Nomad Enterprise 1.5.13 up to 1.6.6, and 1.7.3 template renderer is vulnerable to arbitrary file write on the host as the Nomad client user through symlink attacks. This vulnerability, CVE-2024-1329, is fixed in Nomad 1.7.4, 1.6.7, and 1.5.14.
Affected configurations
• hashicorp nomad (>= 1.5.13 < 1.5.14)
• hashicorp nomad (>= 1.6.6 < 1.6.7)
• hashicorp nomad (>= 1.7.3. < 1.7.4)