CVEvulnerability
CVE-2024-23320
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-02-23
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.
This issue is a legacy of CVE-2023-49299. We didn't fix it completely in CVE-2023-49299, and we added one more patch to fix it.
This issue affects Apache DolphinScheduler: until 3.2.1.
Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Affected configurations
• apache dolphinscheduler (< 3.2.1)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- http://www.openwall.com/lists/oss-security/2024/02/23/3 Mailing List, Third Party Advisory
- https://github.com/apache/dolphinscheduler/pull/15487 Issue Tracking, Patch
- https://lists.apache.org/thread/25qhfvlksozzp6j9y8ozznvjdjp3lxqq Vendor Advisory
- https://lists.apache.org/thread/p7rwzdgrztdfps8x1bwx646f1mn0x6cp Vendor Advisory
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/02/23/3 Mailing List, Third Party Advisory
- https://github.com/apache/dolphinscheduler/pull/15487 Issue Tracking, Patch
- https://lists.apache.org/thread/25qhfvlksozzp6j9y8ozznvjdjp3lxqq Vendor Advisory
- https://lists.apache.org/thread/p7rwzdgrztdfps8x1bwx646f1mn0x6cp Vendor Advisory
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm Vendor Advisory