CVEvulnerability
CVE-2024-23831
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-02-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
Description
LedgerSMB is a free web-based double-entry accounting system. When a LedgerSMB database administrator has an active session in /setup.pl, an attacker can trick the admin into clicking on a link which automatically submits a request to setup.pl without the admin's consent. This request can be used to create a new user account with full application (/login.pl) privileges, leading to privilege escalation. The vulnerability is patched in versions 1.10.30 and 1.11.9.
Affected configurations
• ledgersmb ledgersmb (>= 1.3.0 < 1.10.30)
• ledgersmb ledgersmb (>= 1.11.0 < 1.11.9)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://github.com/ledgersmb/LedgerSMB/commit/8c2ae5be68a782d62cb9c0e17c0127bf30ef4165 Patch
- https://github.com/ledgersmb/LedgerSMB/security/advisories/GHSA-98ff-f638-qxjm Vendor Advisory
- https://github.com/ledgersmb/LedgerSMB/commit/8c2ae5be68a782d62cb9c0e17c0127bf30ef4165 Patch
- https://github.com/ledgersmb/LedgerSMB/security/advisories/GHSA-98ff-f638-qxjm Vendor Advisory