CVEvulnerability
CVE-2024-45693
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-10-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352
Description
Users logged into the Apache CloudStack's web interface can be tricked to submit malicious CSRF requests due to missing validation of the origin of the requests. This can allow an attacker to gain privileges and access to resources of the authenticated users and may lead to account takeover, disruption, exposure of sensitive data and compromise integrity of the resources owned by the user account that are managed by the platform.
This issue affects Apache CloudStack from 4.15.1.0 through 4.18.2.3 and 4.19.0.0 through 4.19.1.1
Users are recommended to upgrade to Apache CloudStack 4.18.2.4 or 4.19.1.2, or later, which addresses this issue.
Affected configurations
• apache cloudstack (>= 4.15.1.0 < 4.18.2.4)
• apache cloudstack (>= 4.19.0.0 < 4.19.1.2)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2 Vendor Advisory
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2 Vendor Advisory
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2 Vendor Advisory
- https://cloudstack.apache.org/blog/security-release-advisory-4.18.2.4-4.19.1.2 Vendor Advisory
- https://lists.apache.org/thread/ktsfjcnj22x4kg49ctock3d9tq7jnvlo Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/10/15/5 www.openwall.com