CVEvulnerability
CVE-2024-46911
4.7 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-10-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-352
Description
Cross-site Resource Forgery (CSRF), Privilege escalation vulnerability in Apache Roller. On multi-blog/user Roller websites, by default weblog owners are trusted to publish arbitrary weblog content and this combined with a deficiency in Roller's CSRF protections allowed an escalation of privileges attack. This issue affects Apache Roller before 6.1.4.
Roller users who run multi-blog/user Roller websites are recommended to upgrade to version 6.1.4, which fixes the issue.
Roller 6.1.4 release announcement: https://lists.apache.org/thread/3c3f6rwqptyw6wdc95654fq5vlosqdpw
Affected configurations
• apache roller (>= 1.0 < 6.1.4)
Related
Weakness · CWE (1)
- CWE-352 Cross-Site Request Forgery weakness
References
- https://lists.apache.org/thread/6m0ghjo9j92qty00t2qb6qf2spds0p5t Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/10/12/1 Mailing List, Third Party Advisory