CVEvulnerability

CVE-2025-26467

8.8 HIGH Published 2025-08-25 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2025-08-25
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-267

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.

Affected configurations

• apache cassandra (>= 3.0.0 < 3.0.31) • apache cassandra (>= 3.11.0 < 3.11.18) • apache cassandra (>= 4.0.0 < 4.0.17) • apache cassandra (>= 4.1.0 < 4.1.8) • apache cassandra (>= 5.0.0 < 5.0.3)

Related

Weakness · CWE (1)

  • CWE-267 Privilege Defined With Unsafe Actions weakness

References