CVEvulnerability
CVE-2025-54782
9.4 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2025-08-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.4 CRITICAL — CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-352, CWE-77, CWE-78
Description
Nest is a framework for building scalable Node.js server-side applications. In versions 0.2.0 and below, a critical Remote Code Execution (RCE) vulnerability was discovered in the @nestjs/devtools-integration package. When enabled, the package exposes a local development HTTP server with an API endpoint that uses an unsafe JavaScript sandbox (safe-eval-like implementation). Due to improper sandboxing and missing cross-origin protections, any malicious website visited by a developer can execute arbitrary code on their local machine. The package adds HTTP endpoints to a locally running NestJS development server. One of these endpoints, /inspector/graph/interact, accepts JSON input containing a code field and executes the provided code in a Node.js vm.runInNewContext sandbox. This is fixed in version 0.2.1.
Affected configurations
• nestjs devtools-integration (< 0.2.1)
Related
References
- https://github.com/JLLeitschuh/nestjs-devtools-integration-rce-poc Exploit
- https://github.com/JLLeitschuh/nestjs-typescript-starter-w-devtools-integration Product
- https://github.com/nestjs/nest/security/advisories/GHSA-85cg-cmq5-qjm7 Exploit, Vendor Advisory
- https://nodejs.org/api/vm.html Product
- https://socket.dev/blog/nestjs-rce-vuln Exploit, Third Party Advisory
- https://github.com/nestjs/nest/security/advisories/GHSA-85cg-cmq5-qjm7 Exploit, Vendor Advisory